Friday, December 19, 2008

Foxmarks Officially Supports Firefox 3.1 Beta

We're excited about the upcoming release of Firefox 3.1, and so are you: though Firefox 3.1 is currently in beta and isn't scheduled to launch until the end of Q1 2009,  many of you have already written us asking to make Foxmarks compatible with the new version. We are happy to say that we have verified that the current version of Foxmarks (v2.6.0) available on the Mozilla Add-ons website is compatible with Firefox 3.1 beta!

To make it official, we have updated the Mozilla website and wanted to let you know that we will now provide support for Foxmarks on Firefox 3.1 beta.

We also have a new version of Foxmarks that contains a handful of small bug fixes. We're holding off on pushing this to the Mozilla website so that we don't annoy everyone with such a minor update, but if you're interested, here's the link to download it: